PONTIAC ZONE TECH FORUMS
 

Go Back   PONTIAC ZONE TECH FORUMS >
Restoration and General Tech
> Cooling & Electrical
User Name
Password

Cooling & Electrical Cooling Systems - A/C - Anything Electrical

Reply
 
Thread Tools
Old 05-17-17, 01:40AM   #1
rexs73gto
rexs73gto
 
Join Date: Apr 2015
Location: Niles MI. 49120
Posts: 226
Default New problem with OPS

I just got the car out about a week ago & I now have a problem with my OPS. The needle on the gauge is way past the 80# mark & it won't come back down. The needle did come down once while I was driving & it read correct for a while while I was driving & then I had to stop for a min. & when i started the car back up it went all the way past the 80# mark again & has not come back down to read correct since. I have good oil pressure as it's not ticking or making any noise & the manual OPS is reading correct that I have under the hood. Any Ideas, did the needle just slip & now is just reading wrong or is there another thing that goes wrong with them that I'm not aware of ?? OH, by the way this is my 73 GTO & it of course has gauges, DUH !!! LOL. Any help ????
rexs73gto is offline   Reply With Quote
Old 05-27-17, 06:38PM   #2
rexs73gto
rexs73gto
 
Join Date: Apr 2015
Location: Niles MI. 49120
Posts: 226
Default

Problem solved, I put in a new OPS & that took care of it. I have never had one push the needle past 80lbs on the gauge. I put in the new OPS & the gauge now reads correct.
rexs73gto is offline   Reply With Quote
Old 05-27-17, 09:16PM   #3
Gach
Administrator
 
Gach's Avatar
 
Join Date: May 2003
Location: ....
Posts: 17,762
Default

Great
__________________
The things they hide, the way they spin things, the excuses that they make and the things they omit.
Gach is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Horn Problem - Help !! gsgto 1958 - 1981 Pontiac Tech & Restoration 3 09-02-16 11:43PM
1969 Rally Gauge problem - HELP larrysfirebird Cooling & Electrical 0 10-01-08 12:01PM
1969 Dash pad and dash bezel installation problem larryharmon 1958 - 1981 Pontiac Tech & Restoration 0 06-06-08 02:25PM
68 FB 350 Need Help With Electric Problem rr67gto 1958 - 1981 Pontiac Tech & Restoration 4 09-03-05 06:19PM
Is There a Problem with our Website?? Need Help?? Pontiac Zone Staff PC And Forum Help Section 0 07-11-05 02:35PM


All times are GMT -3. The time now is 02:53AM.

Featured Ads
Ken's Speed & Machine
Mayhem Turbocharging

Carter Cryogenics.  What can we freeze for you?

Pacific Performance Racing

Central Virginia Machine Service.  Home of the Injun Engine!

All Pontiac Engine Kits

Larry's Auto Machine.  Full serivce auto, marine machine shop, domestic and foreign.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
2001 - 2007 PontiacZone.com
Page generated in 0.06261 seconds with 13 queries