PONTIAC ZONE TECH FORUMS

PONTIAC ZONE TECH FORUMS (http://www.pontiaczone.com/forum/index.php)
-   Carburetion & Fuel sytems (http://www.pontiaczone.com/forum/forumdisplay.php?f=581)
-   -   dominator issue (http://www.pontiaczone.com/forum/showthread.php?t=29182)

frbformula 06-29-13 10:02PM

dominator issue
 
I just put my dominator on the car after doing the 3 circuit to 2 circuit conversion. the carb works great it idles well and the throttle response is way better than the 4150 that was on it. my only issue now is that if i do a quick rev that opens up the mains it will back fire when reving down. any ideas?

Its a 8896 3 circuit
converted to 2 circuit
BLP billet metering blocks
power valve in the front
86 jets in the front 94 in the rear
annular boosters

shaker455 06-29-13 10:55PM

May not have to do with the carb....could be other issues
Plugs
Valves
Timming
Do a cylinder pressure test

frbformula 06-29-13 11:07PM

I will have to check them out. it may be the plugs. i dont have a compression tester but i just took it to the track a week ago with my old carb/intake on it and it made its fastest ever so im guessing the compression is good.

I havent checked the timing in a while. It has always ran good for me so i just never thought about it. the engine is a 463 with 340cfm edelbrocks. Any idea where i should start with on the timing?

shaker455 06-30-13 09:13AM

You'll have to post your combo if you want some tuning advice.

Also, Autozone will lend you a CR tester for free and it is someting you should not assume espically if your racing.

What plugs you running & where they gapped?

frbformula 07-01-13 10:06AM

I will get all the information on the cranking pressure, timing and plugs in the next couple days.

The combo
463
10.5:1
Edelbrock 340cfm heads
Comp Cam 306s
260 @ .050
.555 lift
110 lobe seperation
106 intake center line
2 in headman headers
port matched victor intake
converted 2 circuit dominator
all MSD ignition with 6al-2 box

shaker455 07-01-13 06:23PM

Make sure your MSD button in the cap is not gone....they wipe out easy.

frbformula 07-02-13 09:11PM

did not have time to do compression check but checked the plugs and timing.

the plugs are NGK R5671A-8
gapped to .040
The plugs were pure black so it is definitely running rich
Timing was checked and it was way off. I set it to 32 degrees total timing at 3000

The timing adjustment solved the back fire issue now I just need to dial in the carb.
Shaker can you still help me with this?

shaker455 07-04-13 01:49PM

Quote:

Originally Posted by frbformula (Post 408465)
did not have time to do compression check but checked the plugs and timing.

the plugs are NGK R5671A-8
gapped to .040
The plugs were pure black so it is definitely running rich
Timing was checked and it was way off. I set it to 32 degrees total timing at 3000

The timing adjustment solved the back fire issue now I just need to dial in the carb.
Shaker can you still help me with this?

Yes I can help:

Is your dist locked or unlocked?
If unlocked whats the initinal?
What size airbleeds & IFR"s?
How many turns out are your mix screws?

frbformula 07-05-13 11:20PM

dist is unlocked
18 degrees intial
32 at 2700 rpm
IAB - .062
MAB - .029
Idle jet .039
Tslot Jet - .053
Power valve restricter .053

Mix screws are 1 3/4 out.


I took it for a drive for the first time today and the idle was really rich. The engine kept loading up and I had to keep clearing it out with neutral reves at stop lights.

I think i need to increase the IAB? I could not get it to lean out with the mix screws.

shaker455 07-06-13 01:21AM

If you have no control over mix screws then your throttle blades are not properly set which is easy to do with a Dominator.

Either take the carb off and flip it over or back the screws off and mark them when they engage the blade, start off 1 to 1.5 tuns keeping them even front to rear.

A .053 T-slot jet is kinda small so you should have a wideband O2 sensor to confirm your tune, I recomend an AEM
http://www.amazon.com/gp/product/B00...pf_rd_i=507846

Also make sure your dist is in phase & not spark jumping.

frbformula 07-06-13 07:43PM

Ok. I will be getting one next week. once i have it installed i will get back to you with the readings.

Thanks for the help!

meanone 07-07-13 12:29AM

Hey Formula, your combo and mine were nearly identical. That .039" ifr is too big. You could lean it out by putting in around a .071 iab, or lowering the ifr to about .033. It will still probably be rich at part throttle with a .039 ifr though. Put a .028" ifr in it with a .054" iab. Increase the transition circuit to .059". Your mab is close...I had mine at .025". One thing that doesn't look right is your pvcr. Is it really .053"? I had mine at .089". Jets are good at 86-94. Set your throttle blades so that your transition slots look square. Sometimes you need to drill the throttle plates , or add some by-pass air jets to the stud area to increase the idle speed without cranking the throttle plates open too far.
My car idled around 14.7, cruised at 13.8, and had a wot of 12.5 set up like this.
Hope this helps you straighten your car out, Ronnie.

frbformula 07-07-13 10:33PM

Thank you for some specs meanone.

I got the ilde mix screws responding by doing the procedure that shaker described. I blew out the header gasket taking it for a test drive. This week new header gasket will go in and i will put in an O2 senser. as soon as the O2 is in i will know where I am at and where to go from there.

frbformula 07-14-13 04:38PM

ok got the a/f gauge installed today and fired it for the first time. It will not give a constant number at idle. it toggles between 14 and 17 (maxed out). Is this normal for idle? if i richen the four corner idle then it will just toggle between 12 and 15.

Just off of ilde at 2000rpm the gauge will read pretty steady at 13.2 and anything above 3000 rpm the gauge pegs rich.

So what changes do i do first?

shaker455 07-15-13 05:28PM

Saw your PY post.

Do you have 15" of pipe behind sensor?

Also what fuel you running?.....I don't think a fuel with lead is goiing to let the sensor live long.

Your idle AFR should be 13.2......all other readings need to be under load.


All times are GMT -3. The time now is 12:26PM.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
2001 - 2007 PontiacZone.com

Page generated in 0.04846 seconds with 10 queries